Leave a comment:
Dear Spammers and Trolls: All comments are checked by myself before publishing!
The manual inspection is why it takes some time until your text appears in the comment section (as long as it passes my inspection) - be patient...

I don't answer comments by mail!
Note the rules and my mail address in the column contact!

Norbert

Name:
Comment:
Formular:


----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2018.05.31 08:28:14 (UTC+1)
Name: Horst

Kommentar:
Hallo Norbert,
ja - wenn ich die Spindel starte fliegt mir das um die Ohren :). Die Limit Switches funktionieren tadellos, wenn ich die Spindel aus lasse. Ich habe mir nun ein Shield gebaut, das Optokoppler zwischen Arduino und Endschalter "zwischen schaltet".

Leider tritt das Problem noch immer auf :(. Als nächsten Schritt werde ich wohl die Kabel der Switches (und Stepper) durch geschirmte ersetzen müssen... Ich werde berichten :).

Hast Du sonst noch eine andere Idee?

Gruß,
Horst

Me: Es ist also offensichtlich der Motor, der Störungen verursacht. Größere Entstörkondensatoren (Keramik-Kondensator) direkt zwischen den Motoranschlüssen und Motorgehäuse könnten helfen.

----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2018.05.21 08:50:34 (UTC+1)
Name: Horst

Kommentar:
Moin Norbert,
erst einmal vielen Dank für Deine tolle Anleitung hier. Habe die Spindel in Betrieb nehmen können, AAABER:
Ich habe Limit Switches angeschlossen und die HardLimits deaktiviert ($21=1). Wenn ich nun mit m3 s1000 die Spindel starte, erhalte ich direkt einen HardLimit Alarm. Mit deaktivierten HardLimits funktioniert das. Ich habe an der Spindel einen 100nF Kondensator angebracht, in der Hoffnung, dass das Störungen beseitigt. Hast Du irgendeine Idee, was ich machen kann?

Gruß,
Horst

Me: Tritt der Alarm nur beim Starten der Spindel auf? Funktionieren die Limit Switches, wenn du die Achsen fährst ohne die Spindel zu schalten?

----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2018.04.16 09:43:36 (UTC+1)
Name: Dirk K.

Kommentar:
Hi Norbert,
vielen Dank für diese Seite.
Ich möchte mene Fräse auch in Betrieb nehmen. Sind die Treiber standardmäßig  vom Strom  für 12 oder 24 V auf dem Shield  eingestellt?
Wo misst man am Treiber die 0.54V ?

Me: Die Potentiometer habe ich belassen, wie die waren. Wenn schon Strom einste1llen, dann mit einem Multimeter in der Einstellung für 10A. Bevor das Multimeter in eine Phase eines Schrittmotors geschaltet wird, unbedingt die Maschine ausschalten!. Dann wieder einschalten und den Phasenstrom justieren. Maschine wieder ausschalteun und Multimeter entfernen. Ob 12V oder 24V Eingangsspannung macht an dem Phasenstrom keinen wirklichen Unterschied, meine Maschine läuft in einer Einstellung mit beiden Eingangsspannungen, ich verwende jedoch die 24V an den Schrittmotoren, die 12V am Fräsmotor.



----------------------------------------------------

Page: technics-machines-cnc-T8_en.htm
Date: 2018.03.31 20:20:52 (UTC+1)
Name: GNF

Comment:
I think you misplaced the power supplies on the spindle and the CNC shield. The CNC shield needs 12V and the spindle needs 24V. In your build pictures (figure 13 and 14) you've got it the other way around. Does that work?

GNF

Me: It works both ways. With the 24V on the spindle you get a faster spinning motor, with the 24V on the Mainboard, you get a higher maximum speed for travel along the axes. The choice is yours ;-)

----------------------------------------------------

Page: technics-machines-cnc-T8_en.htm
Date: 2018.02.26 02:57:27 (UTC+1)
Name: Paul Andreasen

Comment:
Thank you SO much! I have been bugging Gearbest for 6 months for help as this stuff is new to me. No response and all the videos I have found are either in high speed with no voice or just dumb!  With your help, I feel this will become usable rather than just wasted money!
Thanks again.

Me: If you buy for very, very cheap in a far far away country, you can't expect to get the same level of support you get from a dealer in your contry. Support is what makes things expensive and that's what dropped first in order to reduce costs...
However, good to see that I could add a bit of that missing support ;-)

----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2018.02.17 12:51:11 (UTC+1)
Name: Entropico

Kommentar:
Erstmal vielen Dank für die Hilfestellung - eine kleine Spende ist unterwegs.
Das Problem ist nun an anderer Stelle gelöst.
Der Fehler lag beim flashen der Firmware vor.
Wenn man die offfiziellen Gearbest Dateien verwendet.
1. Xloader verwenden
2. Flashen mit grbl.hex
3. Flashen mit grbl9.hex

und dann tut auch die Steuerung auch auf Windows mit der beiligenden Gbrl-Controller Software.
Befehle für die Konfiguration sind dann
$100=800
$101=800
$102=800

Liebe Grüße

Me: Daher war meine allererste Frage auch bezüglich der Firmware, da diese eigentlich schon aus der Verpackung heraus auf dem Arduino-Clone aufgespielt ist. Gut dass du deine Maschine zum Laufen gebracht hast und auch Rückmeldung gibst, damit andere den gleichen Fehler schneller ausbügeln können.
Besten Dank für die Spende!

----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2018.02.16 12:28:30 (UTC+1)
Name: Entropico

Kommentar:
Ja dazwischen liegen jeweils 24 V an. Daher sollte das CNC shield selbst vermutlich korrekt seine Arbeit tun.

Me: Dann würde ich mal testen, ob an den "Step" Pins Pulse ankommen, wenn sich der Motor bewegen soll. Dieser Pin ist in Abbildung 13 auf den Treiberplatinen links, der 2. von unten.
Wenn die Motoren angesteuert werden, liegt hier ein Rechtechsignal an und mit dem Multimeter muss eine kleine Spannung zu messen sein. An dem "Dir" Pin (links unten) muss abhängig von der Bewegungsrichtung eine Spannung von 0 oder 5V anliegen.





----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2018.02.16 00:05:47 (UTC+1)
Name: Entropico

Kommentar:
Ja die 24 V liegen an  - per Multimeter direkt gemessen.
Wobei für die Stecker aus Abbildung 15. zu sagen ist, dass diese durchaus defekt sein können. Einer der beiden Stecker ließ keinen Strom durch - in meinem Fall den den ich für 24 V vorsah.
Habe diesen dann durch einen der beiliegenden female Stecker ersetzt. Reduziert auch die Chance auf versehntlich falsches Netzteil anstecken.

Me: In Abbildung 13 muss zwischen der Minus-Klemme (links unten) und den jeweils rechts oben liegenden Pins der 3 Treiberchips überall 24V zu messen sein. Ist das so?


----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2018.02.14 12:05:46 (UTC+1)
Name: Entropico

Kommentar:
Also ich habe von der Gearbest Homepage die offiziell bereit gestellten Dateien (Xloader und .hex) zum Flashen der Firmware verwendet.

An die Verkabelung aus Abb. 13 und Abb. 14 habe ich mich gehalten. Daher funktioniert die Spindel auch.
Nur kann man den Stecker der Schrittmotoren auf die eine oder andere weise (180°) verdreht drauf stecken. Macht das überhaupt einen Unterschied?
Mein Verdacht liegt derzeit eher beim CNC Shield oder den Driver Chips.
Wie testet man soetwas am Besten?

Me: Dass alle 3 Treiber-Chips defekt sind, halte ich für sehr unwahrscheinlich. Wie sieht's mit der Spannungsversorgung aus? Liegen an den Klemmen des Shields die 24V an? Wie herum die Stecker der Motoren aufgesteckt werden ist ist erst einmal egal - die sollten in beiden Fällen laufen.

----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2018.02.13 20:32:14 (UTC+1)
Name: Entropico

Kommentar:
Hallo,

vielen Dank für die Anleitung, dass hat mir als blutigen Anfänger sehr geholfen!

Firmware flashen tut, Spindel auch. Schrittmotoren sind aus unbekannten Gründen nicht ansteuerbar.
Gibt es eine Vorschrift wie die Kabel der Schritmotoren auf das CNC Shield gesteckt werden müssen?
Es gibt leider verschiedene Bilder im Internet.

Wie kann man am Besten testen ob ein Driver Chip abgeraucht oder funktional ist?

Me: Wieso Firmware flashen? Die Maschine kommt mit installierter Firmware. Wenn du da was falsches aufspielst, kann es sein, dass die Motoren nicht mehr korrekt angesteuert werden können.
Abbildung 13 und 14 zeigen die Verkabelung.



----------------------------------------------------

Page: technics-machines-cnc-T8_en.htm
Date: 2017.12.25 19:29:48 (UTC+1)
Name: Simon

Comment:
Hey

Ist es eigentlich möglich bei der T8 ein zu stellen ob
sie sich den nullpunkt merken soll?

Wenn ich im moment mit G92 alles auf null setzte
weiß die fräse beim nächsten befehl nicht mehr wo der nullpunk war.

Oder hat das board vieleicht doch was ab bekommen?

MFG

Me: G92 bedeutet einfach, dass der aktuelle Punkt zum Nullpunkt wird. Wenn du jederzeit zu dem Startpunkt deiner Bewegung (oder zu dem Punkt, den du mit G92 gesetzt hast) fahren willst, musst du zum Modus "Absolute positioning" wechseln (G90). Jetzt fährst du die X-Achse mit dem Befehl X10 nicht um 10mm nach rechts, sondern zum Punkt X = 10. Zum Nullpunkt zurück gehts jederzeit mit X0 Y0 Z0.

----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2017.12.25 01:15:25 (UTC+1)
Name: Simons T8 Funktioniert!

Kommentar:
Ich habe einfach noch 3 mal aus verweiflung dei firmware geflasht und es hat auf einmal funktioniert^^

Kann auch sein das ich einen wackler irgendwo habe weil ich die Fräse zwischendurch auch bewegt habe...

Habe schon ein wenig in Aluminim si0.5 herum gestochert. Geht ganz gut, besser als gedacht, anto backlash nuts sind bestellt, mal schauen wie die sich machen.

Dir Tausend dank für deine Hilfe! Jetzt kann ich die gelernten 9code Befehle endlich in der Praxis ausprobieren :)

Me: Diese verflixten Wackelkontakte aber auch! Gut zu wissen, dass du deine Maschine zum Laufen bekommen hast. Ein Multimeter würde ich aber dennoch auf die Wunschliste setzen, denn damit kann man solchen Fehlern leichter auf die Schliche kommen.

----------------------------------------------------

Page: technics-machines-cnc-T8_en.htm
Date: 2017.12.24 16:37:19 (UTC+1)
Name: Simon

Comment:
Habe ich leider beides nicht :(

Bin wirklich erstaunt das du dir an weihanchten zeit für
mich nimmst :)

Ich habe mir allerdings die Sicherung auf dem cnc Shield angeschaut
und dort ist alles okay. Nichts durchgebrant. Hat auch gestern beim an machen keinen funken gegben.

Was vieleicht noch wichtig ist, ich kann den motor an und aus schalten, allerdings nur wenn ich dazwischen keinen der schrittmotoren anspreche. Sobald ich das mache reagiert der motor nicht mehr und bleibt an/aus.

Me: Dann ziehe die Motortreiber einen nach dem anderen mal aus dem Shield heraus und versuche dazwischen die 3 Achsen anzusteuern. Die Software jeweils neu starten. ACHTUNG!!!! Vor dem Herausziehen oder Hereinstecken der Motortreiber immer zuerst die Spannung ausschalten !!!!
...und natürlich merken, wie herum die Motortreiber auf dem Shield gesteckt waren (vorher Foto machen!). Falsch draufstecken haben die auch nicht gerne!

----------------------------------------------------

Page: technics-machines-cnc-T8_en.htm
Date: 2017.12.24 14:59:12 (UTC+1)
Name: Simons motor dreht

Comment:
Hey :)

Ich habe leider kein multimeter, bin recht neu in dem Gebiet, habe jetzt aber mit Steinzeitmethoden (motor dierekt mit den netzteilen verbinden) die netzteile sowie die steckbuchsen (motor dierekt mit den buchsen mit angeschlossenen netzteilen verbinden) getesstet und festgestellt das die linke buchse (24V) keinen strom weitergegeben hat. Also ausgetauscht. Jetzt kann ich mit GRBL den motor anschalten :)

Leider gehen die schrittmotoren noch immer nicht :(

CNC schield wirklich kaputt?

Me: Ohne Multimeter ist die Fehlersuche sehr knifflig. Hast du eine LED und einen Widerstand circa 1kΩ rumliegen?

----------------------------------------------------

Page: technics-machines-cnc-T8_en.htm
Date: 2017.12.24 11:56:19 (UTC+1)
Name: Simon hat Videos gemacht :)

Comment:
SO, ich habe jetzt mal 2 Videos gemacht, danke erstmal das du dir überhaubt die zeit nimmst :)

Ich muss dierekt beichten das ich gestern abend einmal plus und minus beim anlöten vertauscht habe und somit kurzzeitig 12V verkehrt herum im board waren.

https://youtu.be/XCYeYzvQqXc Beschreibung vom Problem

https://youtu.be/QOPKv5dCpLI Beschreibung der falschen verkabelung.

MFG :)

Me: Falsche Polung ist immer schlecht und kann durchaus das Board (also das Shield mit den Motortreibern zerstören). Der Arduino funktioniert ja offensichtlich noch, da ist also alles in Ordnung.
Das Relais schaltet auch (ist zu hören), aber der Motor läuft nicht an. Da würde ich doch mal testen, ob überhaupt Spannung aus den Netzteilen kommt. Also Voltmeter raus und messen:
1.) Netzteile ohne Verbindung zu den Boards, da sollten 12 bzw. 24V zu messen sein.
Netzteile anschließen und:
2.) Spannung zwischen dem Anschluss COM und ON am Relais sollte 24V betragen, wenn das Relais aus ist.
2a.) wenn da nix zu messen ist, muss zwischen COM und zumindest einem der beiden Pins am Motor 24V zu messen sein, ansonsten ist die Masse nicht richtig am Motor.
3.) bei eingeschaltetem Relais müssen an den beiden Motorpins 24V anliegen.

Also Messen und berichten. Zu dem Motorshield am Arduino kommen wir danach...

----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2017.12.23 22:05:53 (UTC+1)
Name: Simon hat bau Probleme^^

Kommentar:
Ich habe jetzt alles so weit das die Maschine mit dem pc redet. Allerdings sage ich grbl das die T8 10mm fahren soll und sie machts nicht :/.
Hinten auf dem Blauen controler leuchtet eine rote Led und auf dem Relai eine grüne.
Ist das so korrekt?
Die verkabelung habe ich sehr sorgfältig nach diesem video gemacht.
https://www.youtube.com/watch?v=1Zc7SWwsNVU

Me: ...die T8 verfügt über keine Sprachsteuerung ;-)
Du musst also klar sagen, mit welchem Programm du den Befehl sendest. 100m fahren genügt nicht als Befahl, du musst schon dazu sagen, welche Achse sich bewegen soll. Ich sehe mir kein 40-Minuten Video mit Werbung von einer anderen Maschine an, um deine Frage zu beantworten. Ein Video von deiner Maschine und Vorgehensweise mit deiner Software wäre hilfreicher.

----------------------------------------------------

Page: technics-machines-cnc-T8_en.htm
Date: 2017.12.23 14:07:52 (UTC+1)
Name: Simon noch mal :)

Comment:
Ich habe mir nun die Maschiene gekauft und baue sie gerade zusammen, dabei ist mir aufgefallen das derm Verkäufer anscheinend etwas weggespahrt hat. Die 2 Stahl Stangen weilche den Tisch zusätzlich stabilisieren sind nicht mehr vorhanden.
Habe Gearbest desshalb mal angeschrieben.

Aber dafür sind statt 3 jetzt 6 Messing Führugen für die Gewindestangen dabei. Außerdem sind 3 Federn dabei. Wenn ich richtig ermute kann man sich nun selbst anti backlash teile bauen.

MFG

Me: Der Gedanke von Rationalisierung hält offensichtlich auch in China vermehrt Einzug in die Produktion...
6 von den Messing-Muttern waren auch in meinem Bausatz das ist wohl einfach so. Die beiden Rundstäbe sind für die Stabilität sicher nicht soooo sehr von Bedeutung. Wenn's einen zu sehr stört, kann man auch im Baumarkt eine Gewindestange kaufen (M4er oder was so durch das Loch passt) und die einbauen. Es dürfte keinen wirklich merkbaren Unterschied machen.

----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2017.12.19 23:47:08 (UTC+1)
Name: Done (Lugauer Anton)

Kommentar:
Hallo,
ich hab mir die T8 zugelegt, aber wo kann ich eine Software herbekommen um die Maschine zu steuern?

mfg Done

Me: Das geht z.B. mit dem Universal G-Code sender.

----------------------------------------------------

Page: technics-machines-cnc-T8_en.htm
Date: 2017.12.07 23:05:24 (UTC+1)
Name: FELIPE MONTOYA

Comment:
Dear Norbert,

If I can´t load HL340 driver cnc will not function? I assembled all according to video but when I try to use Grbl software nothing happens. Is possible you help me.

Spindle motor goes with plug of the 24V power supply, right? Arduino with 12v


Regards.


Me: What software are you using to send the grbl commands? I did so by using putty on Linux. "Universal Gcode sender" should also work.

----------------------------------------------------

Page: technics-machines-cnc-T8_en.htm
Date: 2017.11.22 11:33:29 (UTC+1)
Name: Simon

Comment:
Ich habe mit diese Maschine gekauft weil ich vor habe damit messing zu bearbeiten.

Ja ich weiß, das wird vermutlich nicht ohne Modifikationen gehen.

Es würde sich dabei nur um 2 bis 2,5mm schaftfräser handeln welche nur 0,1 bis 0,15mm ins Material eintauchen müssten.
Kann die Maschine das?
Wenn nicht ist das kein Problem da ich aufgrund meiner Ausbildung  als Zerspanungsmechaniker selber teile für die Maschine herstellen kann

Me: Ich habe bislang lediglich Holz und Kunststoff mit den mitgelieferten V-Bits bearbeitet. Ob die T8 das Messing mit den Schaftfräsern bearbeiten kann, ist halt erst zu sagen, wenn mann's probiert hat. Der Rundlauf des Fräsmotors ist alles andere als optimal für das Bearbeiten harter Materialien und auch der lange Motorschaft plus Spanner dürfte sich zu stark biegen.  Ohne Modifikationen zweifle ich an guten Resultaten, aber wie gesagt: Versuch macht kluch!

----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2017.10.16 23:00:19 (UTC+1)
Name: Thorsten

Kommentar:
Apropos Enschalter. Ich wollte auf jeden Fall noch welche ergänzen. Es gibt ja auch auf dem Shield Pins, um Endschter auszulesen/ anzuschließen. Muss mich mal informieren wie man die zum laufen bekommt. Besten Gruß

Me: Laut grbl-Wiki müssen die Taster (offen wenn nicht betätigt) nur zwischen Masse und dem betreffenden Pin verkabelt werden:
https://github.com/grbl/grbl/wiki/Connecting-Grbl

----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2017.10.14 10:45:58 (UTC+1)
Name: Thorsten

Kommentar:
Hallo, kein Problem irgendwann hat man ja auch mal Feierabend. Die Software läuft auf dem originalen Board ebenfalls wunderbar!
Hast du denn noch eine Idee, wie man z.B. ein EAGLE Layout am besten fräsen kann? Zu beachten gibt es ja, dass die Frästiefe eingestellt werden muss, dass die Fräsung den Originalmaßen entsprechen muss und, dass der Vorgang pausiert werden muss, wenn das Werkzeug gewechselt werden muss (für verschiedene Bohrungen und Fräsen). Vielen Dank nochmal für deine Hilfe! Gruß.

Me: ...dann war war offensichtlich eine falsche Version aufgespielt.
Die Frästiefe einstellen geht nur, indem man den Fräser mauell zu einem definierten Startpunkt fährt. Es gibt bei der T8 keine Endschalter mit denen das automatisch machbar wäre. Die Werte für Steps per mm sind in grbl anzupassen ($100, $101 und $102):
https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration
Original sind in meiner T8 die Werte:
$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=800.000 (x, step/mm)
$101=800.000 (y, step/mm)
$102=800.000 (z, step/mm)
$110=400.000 (x max rate, mm/min)
$111=400.000 (y max rate, mm/min)
$112=400.000 (z max rate, mm/min)
$120=200.000 (x accel, mm/sec^2)
$121=200.000 (y accel, mm/sec^2)
$122=200.000 (z accel, mm/sec^2)
$130=200.000 (x max travel, mm)
$131=200.000 (y max travel, mm)
$132=200.000 (z max travel, mm)






----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2017.10.13 20:31:45 (UTC+1)
Name: Thorsten

Kommentar:
Ich habe nochmal einiges getestet. GRBL auf einem anderen Arduino zeigt das selbe Verhalten. Mit Putty ansteuern zeigt selbes Verhalten. IN hat nur Verbindung zu IO 12 des Arduinos. Ohne CNC Shield liegen dort ebenfalls 5V an, die selbst langsam sinken, wenn man den Pin und GND mit Händen berührt. Das habe ich aber auch bei einem anderen Pin festgestellt. Getestet habe ich in den Programmen M03(05) und M3(5). Software wird jeweils GRBL 0.9j angezeigt. Ich hab langsam keine Ideen mehr.
...nächster Kommentar:
Ich habe auch einmal jeden Pin des Arduinos durchgemessen, ob er beim Schalten der Spindel von 0V auf 5V gezogen wird. Ich konnte keinen ausfindig machen. Die letzten beiden Möglichkeiten die ich sehe sind der andere Arduino Pin ist jetzt auch nicht mehr i.O. oder die Software GRBL passt nicht zu dem Shield, IO 12 mit SpnEn. Nochmal zusammengefasst: Zwei Arduinos jeweils mit GRBL, Relaisplatine zieht bei 5V an IN 1.8mA, mit GRBL Controller und Putty funktioniert alles bis auf die Spindel. Gruß.
...und nächster Kommentar:
Hallo. Ich habe den Fehler gefunden. Man muss eine Änderung in der config.h des GRBL Sketches vornehmen, damit der SpnEn Pin richtig konfiguriert ist. In der Grundversion ist #define VARIABLE_SPINDLE aktiviert und muss mit // auskommentiert werden, damit die Spindel mit SpnEn geschaltet werden kann. Den Tipp habe ich hier in einem Kommentar von JCDaniel vom 2016-05-06 gelesen: http://diyprojects.eu/arduino-cnc-shield-version-3-0-with-grbl-v0-9/ . Ich hoffe das hilft auch anderen. Gruß Thorsten.

Me: Dieses Mal hattte ich keine Gelegenheit zwischendurch zu antworten, aber ich sehe du weist dir zu helfen ;-)
Besten Dank, dass du dennoch weiterhin gepostet hast und uns auch deine Lösung des Problems verrätst!
Mit grbl habe ich bislang nur sehr wenig experimentiert (nur mal auf eine selbstgebaute CNC Maschine aufgespielt). Irgendwie hatte ich da noch was mit den Pins im Hinterkopf, dass der SpnEn in einer früheren Version von grbl an einem anderen Pin angelegen hatte. Das mit der config.h war mir aber nicht (mehr) bekannt. Software ist schon ganz schön stur...
Klappt denn der originale Arduino-Clon mit der neu aufgespielten Software oder ist da tatsächlich was faul auf der Platine?


----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2017.10.12 22:36:56 (UTC+1)
Name: Thorsten

Kommentar:
Das kann ich nicht sagen, ich habe an der Software bisher nichts gemacht. Ich habe gesehen, dass der SpnEn pin direkt auf den IO 12 des Arduinos geht. Also kommt das Signal direkt von da, was ich auch messen konnte. Entweder stimmt also was nicht mit dem Arduino oder der Software. Ich habe hier noch einen rumfliegen, habe mal versucht da GRBL drauf zu laden. Muss ich morgen nochmal in Ruhe probieren. Mal schauen wie das geht. Wenn du eine Empfehlung hast gerne her damit. Danke soweit, bis morgen

Me: Direkt nach Aufbau einer Verbindung zeigt "putty" an, welche grbl Version auf dem Arduino läuft. Bei mir erscheint die Zeile:
Grbl 0.9g [ '$' for help ]
Die Installationsanweisung für grbl gibts hier:
https://github.com/grbl/grbl/wiki/Compiling-Grbl.

----------------------------------------------------

Page: technics-machines-cnc-T8_en.htm
Date: 2017.10.12 21:43:28 (UTC+1)
Name: Thorsten

Comment:
Ja die Spannung, die dauerhaft bei SpnEn ist, bricht ein von 5V auf 1,2V dann. Ich habe zum testen den Pinheader von SpnEn abgenommen und auf 3,3V und einmal auf 5V gesetzt und in beiden Fällen schaltet das Relais durch, also sollte die Platine i.O. sein. Ich habe mal den Strom gemessen, der fließt, wenn 5V an IN anliegen. Es sind 1,8mA. Mit SpnEn angeschlossen fließt nichts.

Me: Ich frage mich, ob SpnEn per Software auf Eingang mit Pull-up Widerstand geschaltet ist?!? Hast du mit der Firmware am Arduino herumexperimentiert?
Sind die Lötstellen rund um SpnEn am Shield in Ordnung?

----------------------------------------------------

Page: technics-machines-cnc-T8_en.htm
Date: 2017.10.12 21:06:58 (UTC+1)
Name: Thorsten

Comment:
An IN liegen -0,1V, also so gut wie nichts an und an SpnEn liegen 5,08V an. Egal ob Motor ein aus ausgeschaltet über die Software.
Scheint so als würde bei Anschluss von IN die Spannung auf die 1,2V einbrechen.

Me: Scheint es so? Das kann man doch nachmessen. Voltmeter an Klemme und das Kabel dann ebenfalls dranhalten. Sind dann wieder die 1.2V abzulesen?
Du hast vorhin geschrieben, dass du +3.3V an IN gegeben hast und der Motor ist gelaufen. Hast du dazu das Kabel zu SpnEn abgemacht?
Könnte sein, dass der Transistor, der das Relais einschaltet defekt oder falsch angelötet ist (Lötbrücke).


----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2017.10.12 18:58:10 (UTC+1)
Name: Thorsten

Kommentar:
Leider weder noch. Es liegen dauerhaft 1,2V an. Wenn ich testhalber 3,3V anlege schaltet es aber schon durch und die Spindel rotiert. Putty habe ich gerade mal versucht. Unter Seriell habe ich den COM Port (wie bei GRBL angegeben COM5) eingetragen und die Geschwindigkeit auf 115200 gesetzt. Den rest habe ich so gelassen aber es kommt leider nur win Windows-Ton. Sonst kann ich alle Befehle aus deinem Video bei GRBL eingeben, das funktioniert. Die 1,2V liegen nur bei SpnEn an. Verwunderlich.. Gruß

Me: Löse mal das Kabel an IN und messe welche Spannung dann an IN und an SpnEn anliegen.

----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2017.10.11 22:10:53 (UTC+1)
Name: Thorsten

Kommentar:
Danke für die schnelle Antwort. M3 und M5 habe ich gerade mal getestet, da passiert auch nichts.
5V liegt an DC+ und GND an DC-. SpnEn dementsprechend auf IN.
Geplant habe ich damit PCB zu fräsen. Ich bin auf dein Video dazu gespannt.
Gruß Thorsten

Me: Dann muss zwischen GND und IN (SpnEn) +5V anliegen, wenn M3 gesendet wird und 0V wenn M5 gesendet wird. Ist das bei dir so?
Hast du schon einmal versucht, die Maschine mit "putty" anzusteuern, wie ich es im Video gemacht habe?


----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2017.10.11 20:22:18 (UTC+1)
Name: Thorsten Dalkmann

Kommentar:
Hallo,
vielen Dank auch für die Anleitung, ich habe mir die CNC aufgrund dieses Artikels zugelegt.
Die X-Y-Z-Achsen lassen sich zum Glück wunderbar über GRBL Controller 3.6.1 ansteuern.
Nur mit dem Spindelmotor habe ich leider noch keinen Erfolg. Über das Häkchen dafür zum An- und Ausschalten (M03, M05)
sollte sie sich ja ein- und ausschalten lassen, tut sie aber nicht. 5V liegen an der Relaisplatine an. Der Schaltpin sitzt auf SpnEn.
Hat jemand eine Idee?
Viele Grüße Thorsten

Me: Schon mal mit dem Senden von M5 und M3 versucht? Die zusätzliche '0' kann eventuell falsch interpretiert werden. Wo genau an der Relaisplatine liegen die 5V an wenn du was machst?

----------------------------------------------------

Page: technics-machines-cnc-T8_en.htm
Date: 2017.09.21 10:34:01 (UTC+1)
Name: DARE

Comment:
i dont know how to send d video here and am using universal code sender i have loaded the grbl.hex you put here i got some of the set up from this place

Me: Read the colum contact to see how to send me a video.

----------------------------------------------------

Page: technics-machines-cnc-T8_en.htm
Date: (UTC+1)
Name: DARE

Comment:
pls help me  i got t8cnc machine which i will like to use for pcb. when i send the gcode to the cnc, the spindle will not touch the board and if it touch the board it will move away after a few seconds ... i count set the zero home point for it. i get so confuse and so fed up .. pls i need your help on how to srt the zero point and make it engrave perfectly... and also help so as to know how to calibrate it .. thanks for your help

Me: What software are you using on what operating system and how to you proceed EXACTLY to get what you want? I am no mentalist...
A video showing what you are doing could be helpful.


----------------------------------------------------

Page: technics-machines-cnc-T8_en.htm
Date: (UTC+1)
Name: Bob Harper

Comment:
Whew, that went fast. Sorry about the blannk space in the first go. Looks like it should be a soild machine but you showed how loose it was. Can you identify where the movement comes from?
>From the engineering perspective, similar machines have a plate or 3D ptinted angle bracket on the gantry frame.
Still looks like great little machine for the beginner through to an older fella like me that likes to play!
Danke mein freund.

Me: Movement comes mainly from backlash at the ball bearings (fixed ends of the spindles), the linear "bearings" (nothing but iron clamps) as well as the weak and too long shaft of the router motor. It's a nice machine to learn basics of CAM software and of course it's good enough to create decorations on plastics or wood while playing around.
Bitte gerne.

----------------------------------------------------

Seite: technics-machines-cnc-T8_ge.htm
Datum: 2017.07.24 19:06:12 (UTC+1)
Name: Stefan

Kommentar:
Hallo Norbert,

bin am überlegen ob diese T8 auch zum fräsen von PCB geeignet wäre? Hast Du zum Thema PCB Erfahrungen und Hinweise für mich? Danke im vorraus

Gruß Stefan

Me: Ob geeignet oder nicht, hängt von den eigenen Ansprüchen an die Ergebnisse ab. Wirklich haarfeine Leiterbahnen sind mit dieser Billigmaschine nicht machbar. Für einfachste Layouts im 2.54mm-Raster reicht's so einigermaßen. Wenn ich mal wieder etwas Zeit finde, werde ich mit dieser